We are currently experiencing technical disturbances in tool.
Incident Report for Netigate
Resolved
This incident has been resolved.
Posted Mar 21, 2024 - 21:02 CET
Investigating
We are currently experiencing technical disturbances in tool.
Posted Mar 21, 2024 - 15:52 CET
This incident affected: Netigate Tool.