We are currently experiencing issues on the report page

Incident Report for Netigate

Resolved

This incident has been resolved.
Posted Mar 06, 2025 - 15:59 CET

Investigating

We are currently experiencing issues on the report page. We apologize for the inconvenience caused. Newly registered answers will be shown with a delay
Posted Mar 06, 2025 - 14:53 CET
This incident affected: Feedback Reports.