We are currently experiencing issues on the report page
Incident Report for Netigate
Resolved
This incident has been resolved.
Posted Feb 17, 2024 - 10:10 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 17, 2024 - 09:25 CET
Investigating
We are currently experiencing issues on the report page. We apologize for the inconvenience caused and we will share an update as soon as we have more information.
Posted Feb 16, 2024 - 20:17 CET
This incident affected: Reports.