We are currently experiencing delays in our email sendouts.
Incident Report for Netigate
Resolved
This incident has been resolved.
Posted Sep 01, 2023 - 13:24 CEST
Investigating
We are currently investigating this issue.
Posted Sep 01, 2023 - 11:31 CEST
This incident affected: Email sendouts.