Netigate users may experience long loading times.
Incident Report for Netigate
Resolved
This incident has been resolved.
Posted Jun 30, 2022 - 14:38 CEST
Investigating
We are currently investigating this issue.
Posted Jun 30, 2022 - 11:25 CEST
This incident affected: Netigate Tool.