We are currently experiencing issues on the report page. We apologize for the inconvenience

Incident Report for Netigate

Resolved

This incident has been resolved.
Posted Mar 27, 2023 - 08:43 CEST

Investigating

We are currently investigating this issue.
Posted Mar 27, 2023 - 08:21 CEST
This incident affected: Feedback Reports.